Page 1 of 3 123 LastLast
Results 1 to 20 of 55

Thread: Coyote Coupe Project

  1. #1
    Join Date
    Feb 2004
    Location
    Springboro, OH
    Posts
    6,281

    Coyote Coupe Project

    So, I thought I'd pick up from here as to what's up with my car. Plenty of you have seen it go down the track and know it's just scratching the surface of what it's potential is. I'm cool with it, as I wanted to take baby steps since I've not ran anything fast since 2011. I think I've done ok so far with keeping it under control and being able to progress with it. A few weeks ago, towards the end of July, I turned the boost up from approx 14 psi up to 19. I also changed out the trans controller with the GEN 1 quick 6 controller. I didn't soften the shifts up, I had increased the shift firmness with the GEN 2 controller because the shifts were slipping and it wasn't working as well as the GEN 1. It started lifting the wheels on the 1-2 shift and on the 2-3 shift. I didn't think anything of it, and just kept rockin it like a dumbass. So 3 weeks ago, I was doing my license passes, and I was on my first full pass for it, when it shifted from 2 to 3 and all hell broke loose. All kinds of noise under the car and I got it under control, and pulled to the right in case I was leaking anything. I wasn't, but when I got out my left wheel was hanging out of the wheelwell. It wasn't until later when I was strapping it down that I figured out what happened. Check out the pics.



    Since I have no shop, this is how I've been fixing it.


    I got it all back together except for the anti roll bar and I need to get a new tube in my slick, I think it ripped the valve stem from the shock.
    Last edited by NXcoupe; 08-26-2021 at 10:44 PM.

  2. #2
    Join Date
    Aug 2007
    Location
    In a Van By the River !!!
    Posts
    4,670
    Quote Originally Posted by NXcoupe View Post
    So, I thought I'd pick up from here as to what's up with my car. Plenty of you have seen it go down the track and know it's just scratching the surface of what it's potential is. I'm cool with it, as I wanted to take baby steps since I've not ran anything fast since 2011. I think I've done ok so far with keeping it under control and being able to progress with it. A few weeks ago, towards the end of July, I turned the boost up from approx 14 psi up to 19. I also changed out the trans controller with the GEN 1 quick 6 controller. I didn't soften the shifts up, I had increased the shift firmness with the GEN 2 controller because the shifts were slipping and it wasn't working as well as the GEN 1. It started lifting the wheels on the 1-2 shift and on the 2-3 shift. I didn't think anything of it, and just kept rockin it like a dumbass. So 3 weeks ago, I was doing my license passes, and I was on my first full pass for it, when it shifted from 2 to 3 and all hell broke loose. All kinds of noise under the car and I got it under control, and pulled to the right in case I was leaking anything. I wasn't, but when I got out my left wheel was hanging out of the wheelwell. It wasn't until later when I was strapping it down that I figured out what happened. Check out the pics.



    Since I have no shop, this is how I've been fixing it.


    I got it all back together except for the anti roll bar and I need to get a new tube in my slick, I think it ripped the valve stem from the shock.

    Glad it's coming back together Mike !!!

    Definitely has more in it !!!
    Aaron


    F**K Photobucket !!!

  3. #3
    Join Date
    Jan 2009
    Location
    Hillsboro, Ohio
    Posts
    7,916
    I did the exact same thing on a set of UPR uppers a while back on the orange Cobra. Luckily mine was right at the launch so I didn't hurt much but a new tire.

    That car is gonna fly once its all sorted out.
    1992 Mustang LX Coupe, 302, PA C4 and On3 70mm.
    1993 Reef Blue hatch, 347, 3550, and a kit.
    1992 Gould GT project...

  4. #4
    Join Date
    Feb 2004
    Posts
    10,759
    WHoops!!

    *Planning on checking my UPR uppers when I get home.
    http://stangbang.tripod.com/ Where all this began!
    http://stangbang.tripod.com/twisted/ Vinny
    1984 Mustang build @craig_btr on Instagram

  5. #5
    Join Date
    Feb 2004
    Location
    Springboro, OH
    Posts
    6,281
    Quote Originally Posted by draggin50 View Post
    I did the exact same thing on a set of UPR uppers a while back on the orange Cobra. Luckily mine was right at the launch so I didn't hurt much but a new tire.

    That car is gonna fly once its all sorted out.
    Quote Originally Posted by Maximus View Post
    WHoops!!

    *Planning on checking my UPR uppers when I get home.
    These were 21 years old. I called UPR and Sharad sent out new uppers and sphericals with the upgraded 1/2" hardware to me, no questions asked. I'm sending the broke one back to them. I have also softened the shift points up considerably, so no more wheelies on shifts, which is disappointing to the show off in me, but more sensible so I don't break this bitch again. Just when you think you've covered every base and made it unbreakable, it shows you how wrong you were.

    Just glad I didn't lose the car. I was close to 100 when it came apart. It was going to be a hell of a run, but it was only 17 psi after looking at the log. I'm still messing with the PID controls in the boost controller. I may just say screw it and go with an air compressor and dome control, but for now, I look at it as a challenge and am working the problem to get it under control and do what I want it to. Can't wait to get the dyno done so I can get this back onto it and dial this shit in easier.

  6. #6
    Join Date
    Oct 2004
    Location
    Eastgate
    Posts
    3,367
    I bet the jam nut loosened up, and allowed the threaded male adjuster to wobble in the female threaded portion. Pic shows nut is backed all the way off. Uppers being pulled apart under load over and over until the threads failed.

  7. #7
    Join Date
    Feb 2004
    Location
    Springboro, OH
    Posts
    6,281
    Quote Originally Posted by Walter View Post
    I bet the jam nut loosened up, and allowed the threaded male adjuster to wobble in the female threaded portion. Pic shows nut is backed all the way off. Uppers being pulled apart under load over and over until the threads failed.
    Nope, it was tight. I had it adjusted in almost all the way. Both adjusters were tight as possible. It just failed. If it did loosen any, it was because the threads had started to stretch and failed as a result. New ones are torqued as well.

  8. #8
    Join Date
    Feb 2004
    Location
    Springboro, OH
    Posts
    6,281
    Well, went Friday and as I said in another post edgewater let me down. I got my money back and was able to get a partial run in at least for some logging. I put a used set of injectors in that I had cleaned and flowed. One of them was suspect but I gave it a try as it seemed to clean up and work well. It was working right uo til I started it for the third or fourth time with the goofy kid at the lanes kept walking over like we were next, so I'd start it and then the idiot would walk away. So the time he actually was pulling us forward, it starts misfiring.
    So I pulled out all the injectors and it turned out to be the suspect one and it was on the passenger side. I flowed and tested all of them while I had them out and they all work great except one. I put an order into Holley for 2 new 120lb inj and hopefully I'll have them before Friday.

  9. #9
    Join Date
    Aug 2007
    Location
    In a Van By the River !!!
    Posts
    4,670
    Quote Originally Posted by NXcoupe View Post
    Well, went Friday and as I said in another post edgewater let me down. I got my money back and was able to get a partial run in at least for some logging. I put a used set of injectors in that I had cleaned and flowed. One of them was suspect but I gave it a try as it seemed to clean up and work well. It was working right uo til I started it for the third or fourth time with the goofy kid at the lanes kept walking over like we were next, so I'd start it and then the idiot would walk away. So the time he actually was pulling us forward, it starts misfiring.
    So I pulled out all the injectors and it turned out to be the suspect one and it was on the passenger side. I flowed and tested all of them while I had them out and they all work great except one. I put an order into Holley for 2 new 120lb inj and hopefully I'll have them before Friday.

    Let me know when you plan on going again !!!

    I have our annual Gun Bash this weekend ...
    Aaron


    F**K Photobucket !!!

  10. #10
    Join Date
    Feb 2004
    Location
    Springboro, OH
    Posts
    6,281
    This Friday night, then next thursday. Provided my injector shows up and weather cooperates. Update! Just got a shipping notification from Holley!

  11. #11
    Join Date
    Aug 2007
    Location
    In a Van By the River !!!
    Posts
    4,670
    Quote Originally Posted by NXcoupe View Post
    This Friday night, then next thursday. Provided my injector shows up and weather cooperates. Update! Just got a shipping notification from Holley!

    Next Thursday would work ...

    Speaking of injectors, I'll be needing 4 larger ones here before long ...
    Aaron


    F**K Photobucket !!!

  12. #12
    Join Date
    Feb 2004
    Location
    Springboro, OH
    Posts
    8,348
    Quote Originally Posted by NXcoupe View Post
    This Friday night, then next thursday. Provided my injector shows up and weather cooperates. Update! Just got a shipping notification from Holley!
    Got a spare trailer? Maybe Iíll throw a battery in the hoopty and break the engine in properlyz
    They who can give up essential liberty to obtain a little temporary safety deserve neither liberty nor safety. - Ben Franklin



    1998 Mustang GT
    Coyote Swapped


  13. #13
    Join Date
    Jan 2009
    Location
    Hillsboro, Ohio
    Posts
    7,916
    Quote Originally Posted by NXcoupe View Post
    This Friday night, then next thursday. Provided my injector shows up and weather cooperates. Update! Just got a shipping notification from Holley!
    Next thursday at Kilkare? If so Ill make a showing as well, probably with just a camera.
    1992 Mustang LX Coupe, 302, PA C4 and On3 70mm.
    1993 Reef Blue hatch, 347, 3550, and a kit.
    1992 Gould GT project...

  14. #14
    Join Date
    Feb 2004
    Location
    Springboro, OH
    Posts
    6,281
    Nope edgewater.

  15. #15
    Join Date
    Feb 2004
    Location
    Springboro, OH
    Posts
    6,281
    Quote Originally Posted by cstreu1026 View Post
    Got a spare trailer? Maybe I’ll throw a battery in the hoopty and break the engine in properlyz
    Depends on if Neil goes, if not you could use the enclosed

  16. #16
    Join Date
    Feb 2004
    Location
    Springboro, OH
    Posts
    6,281
    Bring this back up. Lots of things to update.

  17. #17
    Join Date
    Feb 2004
    Posts
    10,759
    Quote Originally Posted by NXcoupe View Post
    Bring this back up. Lots of things to update.
    Well thats not a very cool update.....
    http://stangbang.tripod.com/ Where all this began!
    http://stangbang.tripod.com/twisted/ Vinny
    1984 Mustang build @craig_btr on Instagram

  18. #18
    Join Date
    Feb 2004
    Location
    Springboro, OH
    Posts
    6,281
    Quote Originally Posted by Maximus View Post
    Well thats not a very cool update.....
    Lol, was going to edit the post later with pics and more description! I'll update this evening. Can't do the pics from my phone.

  19. #19
    Join Date
    Feb 2004
    Location
    Springboro, OH
    Posts
    6,281
    So long overdue for an update on this thing. Last year, I just was in a funk, dunno what it was, but just didn't feel like going to the track. I only made it out in January and then at one test n tune and a track rental. I was pretty consumed with getting this stupid shop going, but anyway, fun Mike is back and I'm ready to horsepower party again!
    Here's the update, last pass I made was at the 90% fully prepped track at E2O, lol. The car pulled hard to the left all the way down the track. It was dangerous to say the least, especially when I hit the 10% of unprepped track. lol. I figured out my car had a thrust angle that was pretty exaggerated. I studied underneath it, and found the upper control arms didn't look right. I pulled them off and This is what I found:



    Ended up being about 1/2" difference from left to right. I adjust them, and made them the same length. The longer one was loose and had spun its way out. I shortened it to match the other one, and put them in a vice and torqued them to an inch of their little lives. That will some how come back to bite me in the ass, but time will tell. I also numbered the flutes on both so I can turn them and it's a no brainer to figure out if they are the same.

    Last edited by NXcoupe; 03-08-2023 at 08:44 PM.

  20. #20
    Join Date
    Feb 2004
    Location
    Springboro, OH
    Posts
    6,281
    The other thing that was bugging the crap out of me was the placement of the anti roll bar. The damn thing hit the upper control arms just driving through the pits and unloading off the trailer. It also banged hard on launch. I cut that bitch out of there! I used my new plasma cutter and it cut like butter, a little too well. But I got it all ground down, and plated over them with my new welder. You can see the arms are bent from the upper control arm pulling apart 2 years ago, I tried straightening them out as best I could, but to no avail. New one is on order from UPR care of Sharad Radiris, who helped me out big time with a weld your own kit.




    Thanks to my wonderful wife for getting me the new welder for Christmas last year! I ended up with a couple holes in the frame rails, but not a big deal.




    I removed the upper CA and the coil overs as well to gain access to do all this.

    Last edited by NXcoupe; 03-08-2023 at 08:54 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •